piclist 2004\04\24\233820a >
Thread: Still having problems with WinAVR
www.piclist.com/techref/index.htm?key=still+having+problems
flavicon
face BY : Herbert Graf email (remove spam text)



> >I believe I have the "right" ld:
>
> >C:\WinAVR\examples\test>which ld.exe
> >C:\WinAVR\avr\bin\ld.exe
>
> ld is not on my path - I do a
> F:\avrprojects\testgarbage>which avr-ld.exe
>
> which gives me:
>
> C:\WinAVR\bin\avr-ld.exe
>
> Perhaps avr-ld.exe is the correct linker?

       I tried changing the name of ld.exe to something else and got and error
stating ld not found, so I believe it is necessary. Whether it's necessary
it's in the path I don't know.

> Just as a side note, when you did the installation, did you
> select all defaults (expecially the install directory)? It seems
> that all your path info is messed up - I've seen it happen
> in other applications when you go the "custom install" route.
> Insufficient testing.
>
> Ken

       I initially WANTED to install it in a custom place, I absolutely HATE
programs that require they be installed where THEY want to. Unfortunately
since the path I WANTED to use had a space in it everything failed. So I
relented and let it put things where it wanted to.

I've given up for now, it's not worth my time, the project I had in mind
will simply be done with a PIC, at least that flow worked the first time I
tried it (C18). Thanks anyways, TTYL

----------------------------------
Herbert's PIC Stuff:
http://repatch.dyndns.org:8383/pic_stuff/

--
http://www.piclist.com#nomail Going offline? Don't AutoReply us!
email RemoveMElistserv.....spammitvma.mit.edu with SET PICList DIGEST in the body

<NAEALEBPNOHNGKFACEHAEEKAJKAA.mailinglist2@farcite.net> 7bit

In reply to: <000501c42a73$4304cc10$0801a8c0@kl600>
See also: www.piclist.com/techref/index.htm?key=still+having+problems
Reply You must be a member of the piclist mailing list (not only a www.piclist.com member) to post to the piclist. This form requires JavaScript and a browser/email client that can handle form mailto: posts.
Subject (change) Still having problems with WinAVR

month overview.

new search...