piclist 2004\04\24\191608a >
Thread: Still having problems with WinAVR
www.piclist.com/techref/index.htm?key=still+having+problems
flavicon
face BY : Herbert Graf email (remove spam text)



{Quote hidden}

       I have been referencing that document. The only way to get it to get close
to working is to add the c:\winavr\avr\include path to the "Extralib" part
of the makefile. I still end up with the error below.

> Hope this may give you some clues as to where to look.

       Thanks for the help. I hacked my way through the includes, and now I'm
getting this:

Compiling: test.c
avr-gcc -c -mmcu=atmega128 -I. -g -Os -funsigned-char -funsig
ototypes -Wa,-adhlns=test.lst  -std=gnu99 -Wp,-M,-MP,-MT,test
test.c:2: warning: function declaration isn't a prototype
test.c:2: warning: return type of `main' is not `int'
test.c: In function `main':
test.c:3: warning: implicit declaration of function `printf'
as: unrecognized option `-cu=atmega128'
make: *** [test.o] Error 1

What the hell is that all about?


I must say that so far switching to the ATMEL processor has been the MOST
FRUSTRATING THING I've probably ever done microcontroller wise. Nothing is
working right on the software front. Even AVR Studio didn't install
properly, it took a few hacks to get it working.

Now the gcc-avr thing is driving me nuts (aside from the fact that if you
install it to a path with a space in it it completely bungs everything up,
which of course is mentioned nowhere).

On top of that I never received my ATMEL samples, and the samples I did
receive through the Circuit Cellar contest were the wrong ones...

I'm pretty much at the point of just giving up, getting my PIC flow working
was NEVER this hard, and that's including third party tools.

I guess ATMEL still has alot to learn about making the learning curve easy.
Shame really.

----------------------------------
Herbert's PIC Stuff:
http://repatch.dyndns.org:8383/pic_stuff/

--
http://www.piclist.com#nomail Going offline? Don't AutoReply us!
email spam_OUTlistservSTOPspamspammitvma.mit.edu with SET PICList DIGEST in the body

<NAEALEBPNOHNGKFACEHACEJMJKAA.mailinglist2@farcite.net> 7bit

In reply to: <000701c42a49$38009d00$0801a8c0@kl600>
See also: www.piclist.com/techref/index.htm?key=still+having+problems
Reply You must be a member of the piclist mailing list (not only a www.piclist.com member) to post to the piclist. This form requires JavaScript and a browser/email client that can handle form mailto: posts.
Subject (change) Still having problems with WinAVR

month overview.

new search...