piclist 2004\04\24\181226a >
Thread: Still having problems with WinAVR
www.piclist.com/techref/index.htm?key=still+having+problems
picon face BY : Kenneth Lumia email (remove spam text)



I don't know if this is your problem, but you may want to
check the makefile. If you edited it incorrectly (check
the docs for differences between spaces and tabs especially),
it could be messed up.  Also, there should be a section
in there that looks as follows:

# Define directories, if needed.
DIRAVR = c:/winavr
DIRAVRBIN = $(DIRAVR)/bin
DIRAVRUTILS = $(DIRAVR)/utils/bin
DIRINC = .
DIRLIB = $(DIRAVR)/avr/lib

When I run the makefile (from within the programmers
notepad), I get the following command line:

avr-gcc -c -mmcu=atmega16 -I. -g -Os -funsigned-char
-funsigned-bitfields -fpack-struct -fshort-enums -Wall
-Wstrict-prototypes -Wa,-adhlns=command_parser.lst
-std=gnu99 command_parser.c -o command_parser.o

I just tried a make from a dos prompt and the make fails
when attempting to do a link.  You may want to try it all
from within pn. I followed the document
winavr.sourceforge.net/download/install_config_winavr.pdf
and everything setup fine.

Hope this may give you some clues as to where to look.

As far as the installer goes, I loaded a version from late last year
(20030913) and everything  worked fine (WindowsXP pro).


Ken

{Original Message removed}
<000701c42a49$38009d00$0801a8c0@kl600> 7bit

See also: www.piclist.com/techref/index.htm?key=still+having+problems
Reply You must be a member of the piclist mailing list (not only a www.piclist.com member) to post to the piclist. This form requires JavaScript and a browser/email client that can handle form mailto: posts.
Subject (change) Still having problems with WinAVR

month overview.

new search...