piclist 2001\03\23\090900a >
Thread: 16F877 works only when pulldown to ground with resist
www.piclist.com/techref/microchip/devices.htm?key=16F
flavicon
face BY : mike bolton email (remove spam text)



Edmund T wrote

> Subject: [PIC] 16F877 works only when pulldown to ground with resistor
>
>
> Hi,
> Do any kind soul have any ideal why my 16F877 work only when I pulldown all un-used port to ground?
> I used a 10k resistors to do that. Both VDD & VSS are connected and Pin 1 to reset. Chip running at 4Mhz.
>
I presume you don't mean pin 1 is connected to VDD and VSS at the
same time!

I suspect the problem with you having to pull down the unused ports
is you have left them as inputs. A CMOS input can float to any
voltage between Vss and Vdd ( a high impedance). If the voltage is
halfway, the input stage can draw a very high current and upset the
rest of the PIC. Always set unused port pins to outputs.



Mike Bolton   (a 16F877 user with no problems)

--
http://www.piclist.com hint: PICList Posts must start with ONE topic:
[PIC]:,[SX]:,[AVR]: ->uP ONLY! [EE]:,[OT]: ->Other [BUY]:,[AD]: ->Ads


<6B2A243CC@fs1.with.man.ac.uk> 7BIT

See also: www.piclist.com/techref/microchip/devices.htm?key=16F
Reply You must be a member of the piclist mailing list (not only a www.piclist.com member) to post to the piclist. This form requires JavaScript and a browser/email client that can handle form mailto: posts.
Subject (change) 16F877 works only when pulldown to ground with resist

month overview.

new search...