Searching \ for 'help! interesting behaviour of PI18F4520' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/microchip/devices.htm?key=18F
Search entire site for: 'help! interesting behaviour of PI18F4520'.

Truncated match.
PICList Thread
'help! interesting behaviour of PI18F4520'
2010\01\08@010254 by Sergey Dryga

flavicon
face
Hello all,

hope the collective brain has the answer.  
Problem: unable to write to any variables
Setup:
PIC18F4520, CCS compiler v.3.242 (older version, but worked fine so far)
I have 2 almost identical boards (difference is type of solder used).  One board
performs as expected.  PIC on another has oscillator running, CCP/PWM module
works fine, I can change state of output pins (blink a led) when stepping
through the code.  But none of variable assignments work (e.g.

int i = 6;
while (i) {
output_toggle(LED);
i--;
};

does not assign or decrement i!)

I have replaced the PIC n that board,- still same behaviour.  I have not seen
this before and a bit stumped.  A solution could be to discard the board and
make another one, but I would like to find out reason for this.  

Any hints/help is grreatly appreciated.

Thank you,

Sergey Dryga

2010\01\08@023344 by Richard Prosser

picon face
Hi Sergey,
Are the supply voltages the same? - could you be getting instability
on one of them? (Not necessarily the one that isn't working correctly
although that's the obvious one)
Is the reset line terminated correctly?
Is the program verified as written to flash OK?
Unused inputs - could any be being pulled outside the supply voltage.
Includes any analogue inputs.
Are you using the RC oscillator or xtal/resonator? have you tried
alternative clock configurations?

RP



2010/1/8 Sergey Dryga <spam_OUTsergeyTakeThisOuTspamdryga.us>:
{Quote hidden}

>

2010\01\12@220058 by Raymond Hurst

picon face
Look at the assembly language.
The code may be compiled out.

Richard Prosser wrote:
{Quote hidden}

>> --

More... (looser matching)
- Last day of these posts
- In 2010 , 2011 only
- Today
- New search...