Searching \ for 'Weird problems' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/index.htm?key=weird+problems
Search entire site for: 'Weird problems'.

Truncated match.
PICList Thread
'Weird problems'
1997\08\18@221058 by Mike DeMetz

flavicon
face
After checking my software over and over I found the problem with my
simple serial tx PIC device to be the 16C54JW. It is one that has
been mistreated. The problem is none of the i/o pins will sink
low enough for TTL. They seem to source OK(LED) and on the scope the
outputs go down to less than 1 volt with no load but only about 1.5
volt with a MAX232 ic. (Everything worked fine with a 16C84).
Anyone seen this type of behavior?

Also the program I wrote was done in Notepad with an imported TX
routine. MPASM from windows assembles it with no problem, but when
run from Build in MPLAB I get over 40 errors (movlw Illegal Opcode,
label after column one). Any ideas?

1997\08\19@021348 by electronics

flavicon
face
Mike DeMetz wrote:
>
>  After checking my software over and over I found the problem with my
> simple serial tx PIC device to be the 16C54JW. It is one that has
> been mistreated. The problem is none of the i/o pins will sink
> low enough for TTL. They seem to source OK(LED) and on the scope the
> outputs go down to less than 1 volt with no load but only about 1.5
> volt with a MAX232 ic. (Everything worked fine with a 16C84).
> Anyone seen this type of behavior?
>
>  Also the program I wrote was done in Notepad with an imported TX
> routine. MPASM from windows assembles it with no problem, but when
> run from Build in MPLAB I get over 40 errors (movlw Illegal Opcode,
> label after column one). Any ideas?
Add directive:
       LIST    FREE
regards Vladimir

1997\08\21@093205 by miked

flavicon
face
>   Also the program I wrote was done in Notepad with an imported TX
> > routine. MPASM from windows assembles it with no problem, but when
> > run from Build in MPLAB I get over 40 errors (movlw Illegal Opcode,
> > label after column one). Any ideas?
> Add directive:
>         LIST    FREE
> regards Vladimir
That did not fix it, but it led me to what did. I needed the processor
directive  LIST p=16C84. I was not using it since I was switching back
and forth from an 16C54 to 84.

More... (looser matching)
- Last day of these posts
- In 1997 , 1998 only
- Today
- New search...