Searching \ for 'Stim Files Not Working' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/index.htm?key=stim+files+not+working
Search entire site for: 'Stim Files Not Working'.

Truncated match.
PICList Thread
'Stim Files Not Working'
1998\01\23@141809 by Benjamin Wirz

picon face
Hello,

       I can't seem to get a stim file to work with a 12C509 in MPLAB
6.31.  I have done this before on another machine without problems and
now I don't see any changes in my I/O register.  Anyone have a
suggestion?

Thanks,

Ben

!
! Serial Input @ 2400 bps Test
! Bits are sent 0, 1, 2, 3, ...
STEP    GP3
1       1
500     0
917     1
1333    1
1750    0
2167    1
2583    0
3000    1
3417    0
3833    0
4250    1
4667    0
5083    1
5500    0
5917    0

1998\01\23@172007 by myke predko

flavicon
face
Hi Ben,

GP3 is the _MCLR/GP3 bit.  You have to do two things to disable _MCLR before
it will run with the simulator.

1.  Make sure you have a "__CONFIG" Statement.  ie:

__CONFIG _CP_OFF & _IntRC_OSC & _MCLRE_OFF  & _WDT_OFF

Make sure it does not start in the first column and _MCLRE_OFF is specified.

2.  In MPLAB, go into:

Options -> Processor Setup -> Hardware

And then click off "MCLR Enable".

Good luck,

myke

{Quote hidden}

"Programming and Customizing the PIC Microcontroller" is the January 1998
Electronics Book Club Main Selection.  See "http://www.myke.com".

More... (looser matching)
- Last day of these posts
- In 1998 , 1999 only
- Today
- New search...