Searching \ for 'Slowness with MPLAB' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/microchip/languages.htm?key=mplab
Search entire site for: 'Slowness with MPLAB'.

Truncated match.
PICList Thread
'Slowness with MPLAB'
1999\04\08@093611 by Norm

picon face
Hello everybody,

I am presently using MPLAB (running WIN98 on a P166) and a PICMASTER to
develop software for the 17C756. All of my modules are written in assembly
only.  I am using MPASM and MPLINK (from within MPLAB) to assemble and link
my 10 modules.  However, to complete a full build, it takes MPASM about 90
seconds to assemble all files, and then it takes MPLINK about 30 seconds to
link these modules together after assembly.  Having done most of my
assembling and linking in the DOS world (where it typically takes less than
5 seconds to complete), this 2 minute build time unacceptable to me (my
assembled code thus far is less than 1K).

Can anybody recommend a third-party applicaton or offer suggestions to speed
up this process (aside from upgrading my PC or changing to a stable OS)?

Thanks,

Norm Siegel


'Slowness with MPLAB'
1999\05\06@165448 by Mark Willis
flavicon
face
There was a "Speedup" application that someone has IIRC that helped
earlier, also if you move your mouse around in the MPLab screen that
helps a lot - I don't have the URL handy & am in a time crunch just now,
catching up on old mail in between disasters today <G>  I think this one
"fell through the cracks" somehow.

 Does it noticeably speed up your compile time, Norm, if you keep
wiggling the mouse constantly, on the MPLab window while MPASM/MPLink
are running?

 (Running on too little sleep yet today, today's a "Take the day off to
survive!" day <G>)

 Mark

Norm wrote:
{Quote hidden}

1999\05\09@134607 by Mik Kim

flavicon
face
Hi,

THe speed.exe program works mostly for simulation. I don't think it
affects compile (if so, very minimal). It sends "NULL" events to MPLAB
to force it to work.

I have an old 6x86-166 (pre M-II), and even the most complex programs
(about 20k) compiles in less than 10 seconds with MPLAB. How much RAM (I
have 32M)? Do you have other apps running (ie, mail, news, web
programs)? Do you play MP3 while compiling? I notice this slows down
quite a bit, but not as much as what you describe. Maybe quitting all
apps (including things on system tray) may help.

Mark Willis wrote:
{Quote hidden}

More... (looser matching)
- Last day of these posts
- In 1999 , 2000 only
- Today
- New search...