Searching \ for 'PIC START PLUS Comm Problems' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/microchip/devices.htm?key=pic
Search entire site for: 'PIC START PLUS Comm Problems'.

Truncated match.
PICList Thread
'PIC START PLUS Comm Problems'
1998\02\26@003219 by Mike

flavicon
face
I know this has been talked about recently, but I've tried all the
suggestions and still can't get my PIC START to talk with my PC.  Here is
what I have done so far, and maybe someone can tell me what I haven't done
yet to get my PC and programmer talking with each other.  (NOTE: I have
tried this on a 486 PC running windows 95, and a 386 running windows 3.11,
but neither will talk with the programmer.  I'm wondering if maybe the
programmer is faulty.)

1.  Started MPlab with mouse still connected to com 1.
2.  Disconnected mouse and connected programmer cable to com 1.
3.  Turned power on to programmer--the programmer power light came on.
4.  Tried to "enable programmer" but got a failure message saying can't open
communications with programmer.
5.  I ensured that the "commport=1" was in my ".ini" file.
6.  I set up the comm port at 19200 baud per the release notes...tried 9600
also which is my default setting--still no luck with either setting.
7.  Disabled the FIFO for the port.
8.  Tried using the alternate "mpplus.dll" from microchip--this caused the
486 PC to not allow me to open MPLab--got an error message about the BWCC
file being old.  I get this same message when I try to open an ASM file from
file manager/explorer, so not sure if this is a valid error or not.  The 386
would let me open MPlab, but still no comm with programmer.
9.  Checked the system.ini to ensure I had the proper com.drv installed for
this version of MPlab (3.10.00) and PIC START (1.21.00).
10.  Since I have tried this on two different PC's, and loaded the 486 from
CD-ROM and the 386 from disks (3.5"), I assume that the software is not at
fault.

Since I bought this from Digi-Key, I hate to send it back as they won't have
any means to check it, only replace it or refund my money.  I want the
programmer, but would like to get it working and not just get my money back.

Any ideas or suggestions from anyone???

Mike



Regards...
Mike Hall - "http://members.aol.com/mhall34450/"
WB8ICN
Dayton, Ohio

1998\02\26@011219 by tjaart

flavicon
face
Mike wrote:

{Quote hidden}

Even with the new PS+ driver for MPLAB, I also get the occasional comms
failure with my PS+. What usually saves the day, is the following :

Open up a Telix session on the comm port you have your PS+ on 9600 baud.
Type a few characters. If your PS+ works, you should get some garbage
back.
Close the Telixs session and try to enable the PS+ again.

(If you don't get anything back, fiddle with your power and RS232 cables
until you do.)

I think Mchip screwed up on the comms routines in MPLAB, or in the PS+,
or both. With the current rate of updates, you shouldn't hold your breath
for a real fix soon...

--
Friendly Regards

Tjaart van der Walt
spam_OUTtjaartTakeThisOuTspamwasp.co.za
_____________________________________________________________
| WASP International http://www.wasp.co.za/~tjaart/index.html |
|       R&D Engineer : GSM peripheral services development    |
|   Vehicle tracking | Telemetry systems | GSM data transfer  |
|    Voice : +27-(0)11-622-8686 | Fax : +27-(0)11-622-8973    |
|              WGS-84 : 26¡10.52'S 28¡06.19'E                 |
|_____________________________________________________________|

1998\02\26@021217 by Ivan Kocher

flavicon
face
Mike wrote:
> 1.  Started MPlab with mouse still connected to com 1.
> 2.  Disconnected mouse and connected programmer cable to com 1.

Windows makes unavailable the serial port the mouses uses.  No way
around this.

I suggest that you start windows without mouse, via setup if necesary,
or tell windows the mouse is in com2, where there is no com2.
In this way you might be able to make it work, but sorry, no mouse...

Although keyboard isn't so hard to use ;) ...

Ivan

1998\02\26@022503 by Richard Nowak

picon face
I believe the mouse driver is still loaded at step 2 and beyond which
precludes the possibility of MPLAB from ever getting control of the port.

I would think that you would not want to give up the mouse when using MPLAB
anyway.

Since the mouse is on port 1 you cannot use port 3 for the PICSTART since it
uses the same IRQ.  This leaves ports 2 and 4. If you have an internal modem
it is most likely on port 2 so you are left with port 4. You can't use the
modem and PICSTART at the same time. The BIOS settings have to make sense
with what you are trying to do in Windows.

Rich

At 12:26 AM 2/26/98 -0500, you wrote:
{Quote hidden}

=========================================
= Abolish the Income Tax! Fire the IRS! =
= http://www.nrst.org/                  =
=========================================

1998\02\26@155634 by H.P.d.Vries

flavicon
face
Mike wrote:
{Quote hidden}

Maybe try starting windows without a mouse plugged in? Maybe windows
won't allow access to COM1 when it has assigned a mouse-driver to it.
(try disabling mouse driver in DOS as well)
Or else try connecting it to COM2 (i have) You'll probably have to get a
25->9 pin adaptor, or get a new connnector to your motherboard.

Good luck

Hans

1998\02\26@213436 by pas3

picon face
Mike wrote:
{Quote hidden}

Did you make your own cable ? If so the information in the book is
incorrect. The 9 pin connector on the Pic Start Plus is as follows:

25 pin ( PC_Host )              9-Pin ( PICSTART PLUS )

2 TX                            3 RX
3 RX                            2 TX
20 DTR                          4 DATA READY
7 COMMON                        5 COMMON
6 DSR                           6 +5
4 RTS                           7 CTS
5 CTS                           8 RTS

Hopes this helps. Joe K.@ PAS

1998\02\26@225323 by Mike

flavicon
face
I finally figured out how to get my pic start to communicate with my PC's...

First of all, thanks to Tjaart and Ivan, who gave me some inspiration to
figure this out.  I couldn't live without my mouse so using comm port 1 was
not an option.  I had to wire up a cable to use comm port 2 and then
reconfigure my port settings and the .ini file to get it working.  I can now
use my pic start on a 386 and 486 at home, and the pentinum at work.  I did
discover a couple of things that future buyers of the pic start might want
to consider...be aware of:

       1.  Microchip ships the pic start with a six foot, db9 connector
serial cable.  This is rather misleading since comm port 1 isn't really a
good option to use, unless your willing to give up your mouse! ...and can
get it to work on comm port 1.

       2.  The wiring suggestion that microchip shows in the manual to use
another port, indicates that both pins 2 (TX) and 3 (RX) of the db25
(PC-host) connector should be tied to pin 3 (RX) of the db9 (PIC START PLUS)
connector.  I found that if you connect RX to TX and TX to RX, respectively
from the db25 to db9 connectors, the programmer works fine.  Not sure why
they show this wiring as a tied point on the db9 connector.  I didn't try it
and don't plan on trying it...seems not to be a good idea in my book--how
would the programmmer talk to the PC???  Someone might want to comment on
this and tell me why, so if I'm wrong, I don't walk around the rest of my
life being dumb and stupid about this wiring, (smile).

Again thanks for the words of wisdom and inspiration folks!!  Now on to some
fun projects--will let ya'll know how they come out...

Mike



Regards...
Mike Hall - "http://members.aol.com/mhall34450/"
WB8ICN
Dayton, Ohio

1998\02\26@230809 by Mike

flavicon
face
To Rich, Hans, and Joe,

       just saw your responses to my initial post about my comm problem
with the pic start. I did go to comm port 2 and did discover the incorret
wiring when I made cable.  Has anyone told microchip about this wiring
error?  I called the local office here in Dayton today but all the tech's
were out.  I will follow-up tomorrow afternoon if I can get back to my
office in time before they close for the weekend.

Thanks guys!!

Mike

Regards...
Mike Hall - "http://members.aol.com/mhall34450/"
WB8ICN
Dayton, Ohio

1998\02\26@232225 by CCSystems

picon face
At 10:49 PM 2/26/98 -0500, Mike <.....wb8icnKILLspamspam@spam@DNACO.NET> wrote:
>I finally figured out how to get my pic start to communicate with my PC's...
>

Now, if only there was a way to get it to work on NT...

***

This e-mail address is a 'facsimile receiver' as defined
by Title 47 USC. Sending unsolicited commercial e-mail
to this address is a violation of US Federal Law.

1998\02\27@012348 by wterreb

flavicon
face
{Quote hidden}

Mike

It does indeed sound like there is a fault with your Picstart
hardware.  This is not impossible.   I had a Picstart Plus that one
day just stopped communicating.  I tried everything, including
upgrading the firmware.  Then out of desperation I borrowed a
firend's Picstart Plus and "Voila!" it worked on my computer.  This
made me realize that it was a hardware problem, so I returned it to
our local Microchip agent who sent it back to Microchip to have it
fixed.  I must warn you that it took at least six months before I had
it back and I still had to pay for the shipping as well.   In
fairness to Microchip, I do not think it was their fault... I rather
suspect that our local agent waited until he had several broken PS+'s
before he sent them away.  Hope you have better luck.

Suggestion:  Maybe you can also borrow another Picstart Plus from a
friend to try on your computer to see if it is indeed a harware
problem in your unit?

Rgds
Werner
--
Werner Terreblanche     users.iafrica.com/w/we/wernerte/index.htm
.....wterrebKILLspamspam.....plessey.co.za (work)  OR  EraseMEwernertespam_OUTspamTakeThisOuTiafrica.com  (home)
Plessey SA, PO Box 30451,Tokai 7966, Cape Town, South Africa
or at home : Suite 251, PostNet X5061, Stellenbosch, 7599
Tel +27 21 7102251  Fax +27 21 7102886  Home +27 21 8523249
------------------------------------------------------------

More... (looser matching)
- Last day of these posts
- In 1998 , 1999 only
- Today
- New search...