Searching \ for 'PIC 14000 A/D problems' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/microchip/ios.htm?key=a%2Fd
Search entire site for: 'PIC 14000 A/D problems'.

Truncated match.
PICList Thread
'PIC 14000 A/D problems'
1997\05\12@060123 by Corne Smith

flavicon
face
Hi
I am stumped by a problem that involves the A/D channel AN1.
I convert two voltages on the A/D that is in a range of
0 - 1v.I use channels AN0,AN1.
When I convert on channel AN0 I get a nice conversion and can see the
charging and discharging on the CDAC pin like the following
   /|       /|       /|       <- 1.0v
 /  |___/ |___/ |__   <-0.0v

now when I switch to the AN1 channel I get a counter overflow int.
and the cap charges up to 5v ,but both inputs are the same (max 1v).
I can see it charges to 5v by the wave form on the CDAC pin.
which looks like:

      ____                ____         <-5v
     /        |              /        |
   /          |            /          |
_/            |_____/            |___  <-0v

I have checked that the BAISOFF bit in the SLPCON reg is set ,to make
it a normal A/D input.
The direction of the pins on PORTA is inputs for AN0,AN1
and the ADCON1 has bits 1 and 0 set as 1,0 respectively to make
the first two pins of PORTA  analog  inputs ,and the rest digital ones.

Is there something I missed ?Why doesn't the A/D module get channel
AN1 at its input to convert it?

Any input will be appreciated
Thanks
Corne

1997\05\14@063550 by Corne Smith

flavicon
face
Hi people
I've sent a question on the list a few days ago
and thanks for the people that have responded
but unfortunately I've tried all the things before.
As soon as I select the AN1 channel for a normal voltage measurement
I've disabled the zeroing network via the pin4 in the SLPCON reg and no
luck.
I gives me the described waveform, have anybody physically done
normal voltage level measurements by disabling the Zeroing network?
Can you give me a copy of the code ,please ??

Thanks
Corne

(Previous letter)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Hi
I am stumped by a problem that involves the A/D channel AN1.
I convert two voltages on the A/D that is in a range of
0 - 1v.I use channels AN0,AN1.
When I convert on channel AN0 I get a nice conversion and can see the
charging and discharging on the CDAC pin like the following
   /|       /|       /|       <- 1.0v
 /  |___/ |___/ |__   <-0.0v

now when I switch to the AN1 channel I get a counter overflow int.
and the cap charges up to 5v ,but both inputs are the same (max 1v).
I can see it charges to 5v by the wave form on the CDAC pin.
which looks like:

      ____                ____         <-5v
     /        |              /        |
   /          |            /          |
_/            |_____/            |___  <-0v

I have checked that the BAISOFF bit in the SLPCON reg is set ,to make
it a normal A/D input.
The direction of the pins on PORTA is inputs for AN0,AN1
and the ADCON1 has bits 1 and 0 set as 1,0 respectively to make
the first two pins of PORTA  analog  inputs ,and the rest digital ones.

Is there something I missed ?Why doesn't the A/D module get channel
AN1 at its input to convert it?

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

More... (looser matching)
- Last day of these posts
- In 1997 , 1998 only
- Today
- New search...