Searching \ for 'MPLAB and Picstart Plus compatibility.' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/microchip/languages.htm?key=mplab
Search entire site for: 'MPLAB and Picstart Plus compatibility.'.

Truncated match.
PICList Thread
'MPLAB and Picstart Plus compatibility.'
1996\10\15@094926 by Werner Terreblanche

flavicon
face
Hi everybody

 I know there was a recent discussion of this topic on the Piclist,
but at the time I didn't really pay much attention and now I whish
that I did!  :(

I wanted to upgrade to MPLAB v3.10 because this was supposed to
support my newly aquired PCB & PCM C compilers from CCS.  Only now
that I upgraded, I find that I can't communicate with the  PICSTART
Plus programmer anymore.    I am using the recommended Picstart
plus software v1.20.07.

Does anybody else have the same problem, or is my Picstart Plus
programmer faulty?  I know there is also an upgrade hex file
available from the Microchip website for upgrading the firmware, but
I assumed this was only neccessary if you wanted your programmer to
support all the latest hardware.  Will my problems dissapear if I buy
a new 17C44 and upgrade my firmware?

I'm going to try and go back to my previous version of MLAB V3.01
now, because version 3.09 is no longer available from Microchip's
website.  Hopefully my programmer will start to work when I do this,
but this seems to be my only hope.... or is it?

Regards
Werner





 PICSTART Plus v1.20.07 requires MPLAB v3.10 or greater.  PICSTART
 Plus v1.20.07 will not work with older versions of MPLAB, and MPLAB
 v3.10 will not work with older versions of PICSTART Plus. These
 versions include compatibility checks to ensure that version
 requirements are met.
--
Werner Terreblanche   Tel +27 21 7102251   Fax +27 21 721278
spam_OUTwterrebTakeThisOuTspamplessey.co.za (work) OR .....wernerKILLspamspam@spam@aztec.co.za  (home)

1996\10\15@120301 by Todd Peterson

picon face
At 03:58 PM 10/15/96 GMT+2, you wrote:

>I wanted to upgrade to MPLAB v3.10 because this was supposed to
>support my newly aquired PCB & PCM C compilers from CCS.  Only now
>that I upgraded, I find that I can't communicate with the  PICSTART
>Plus programmer anymore.    I am using the recommended Picstart
>plus software v1.20.07.
>
>Does anybody else have the same problem, or is my Picstart Plus
>programmer faulty?  I know there is also an upgrade hex file
>available from the Microchip website for upgrading the firmware, but
>I assumed this was only neccessary if you wanted your programmer to
>support all the latest hardware.  Will my problems dissapear if I buy
>a new 17C44 and upgrade my firmware?
>
>I'm going to try and go back to my previous version of MLAB V3.01
>now, because version 3.09 is no longer available from Microchip's
>website.  Hopefully my programmer will start to work when I do this,
>but this seems to be my only hope.... or is it?


Can someone perhaps shed the light of experience on this?  I too would like
to use the CCS PCM C Compiler with MPLAB, but have heard of trouble from the
latest version of MPLAB.

Also, what will using a new 17C44 do for the Picstart Plus?

I don't believe the CCS C Compiler can be used with version 3.09, can it?

Thanks for the time,

Todd Peterson

1996\10\15@122419 by myke predko

flavicon
face
Werner wrote:

>
>I wanted to upgrade to MPLAB v3.10 because this was supposed to
>support my newly aquired PCB & PCM C compilers from CCS.  Only now
>that I upgraded, I find that I can't communicate with the  PICSTART
>Plus programmer anymore.    I am using the recommended Picstart
>plus software v1.20.07.
>
>Does anybody else have the same problem, or is my Picstart Plus
>programmer faulty?

Werner, I just changed to a new PC and as part of the change over, I
installed MPLAB 3.10.03 directly (into the Windows 95 that came with the PC)
and was able to program directly to my PICSTART Plus without any problems.

But, I have had a number of problems upgrading MPLAB on my old PC and here
are the two big things that I are a few things I learned:

1.  Terminate your old MPLAB with extreme prejudice.  This means after
"Uninstalling" MPLAB, go through your directories and search out any
remaining files and delete them.  Delete the subdirectory you loaded MPLAB
onto.  Then, copy in and Delete a couple of big unrelated files just to make
sure that your FAT file is changed.  I found if your MPLAB subdirectory is
not nuked, the new version of MPLAB wouldn't work.

2.  Look for all copies of DWCC.DLL and replace them with the latest copy
(comes with MPLAB or you can get it of the Microsoft ftp server).  I got
caught on this one right at the start.

I found that going from 3.09 to 3.10.01 required Uninstalling 2x and then
the programmer would work.

You might also check the Serial Port to see if you are using the correct one.

Good Luck, I know it can be a pain in the ass, but it is worth it,

Myke

Do you ever feel like an XT Clone caught in the Pentium Pro Zone?

1996\10\15@134457 by Shawn Ellis

flavicon
face
>>I wanted to upgrade to MPLAB v3.10 because this was supposed to
>>support my newly aquired PCB & PCM C compilers from CCS.  Only now
>>that I upgraded, I find that I can't communicate with the  PICSTART
>>Plus programmer anymore.    I am using the recommended Picstart
>>plus software v1.20.07.
>>
>Can someone perhaps shed the light of experience on this?  I too would like
>to use the CCS PCM C Compiler with MPLAB, but have heard of trouble from the
>latest version of MPLAB.
>
Well, I use the CCS compiler with great success with a RICE16 ICE and a
picstart16C.  The problems I have encountered are:

It doesn't save parameters like object file extensions and fonts and stuff.
So you can compile and not really get a new .HEX file.  So make sure your
object file types are set right.

Otherwise, call and consult with CCS, I have found them to be very
responsive in dealing with problems with my RICE.

1996\10\16@011419 by tjaart

flavicon
face
Werner Terreblanche wrote:
>
> Hi everybody
>
>   I know there was a recent discussion of this topic on the Piclist,
> but at the time I didn't really pay much attention and now I whish
> that I did!  :(
>
> I wanted to upgrade to MPLAB v3.10 because this was supposed to
> support my newly aquired PCB & PCM C compilers from CCS.  Only now
> that I upgraded, I find that I can't communicate with the  PICSTART
> Plus programmer anymore.    I am using the recommended Picstart
> plus software v1.20.07.

Contact Willem Hijbeek (willem.hijbeekspamKILLspamMicrochip.com). He is the local
representative of Microchip in SA. Explain your problem to him. I think
you will be surprised at the good level of back-up here in the sticks.
Expect a really quick response.

Friendly regards

Tjaart van der Walt
________________________________________________________________
R&D Engineer       | GSM vehicle tracking and datacomm solutions
WASP International | +27-(0)11-622-8686 | http://wasp.co.za

1996\10\16@024450 by Werner Terreblanche

flavicon
face
Hi all

Special thanks to Myke Predko <.....mykeKILLspamspam.....PASSPORT.CA> and  Todd Peterson
<EraseMEelabspam_OUTspamTakeThisOuTNETINS.NET> for their responses to my posting and Myke's help
on getting MPLAB to work with the Picstart Plus programmer.  It finally seems to
work now.

{Quote hidden}

I also thought so at first, but the PCM complier does work with the
MPLAB v3.10.   Even though the PCB compiler is not listed when you select
add/modify in the edit menu, you can still add it manually by typing
in PCML on the command line.

>Also, what will using a new 17C44 do for the Picstart Plus?

As far as I can tell, you get to program some addtional devices not
supported in the older version.  I haven't really made a comparison
as to exactly what devices, but I seem to recall reading that
somewhere in the documentation.  It might be worth the trouble after
all.

>I don't believe the CCS C Compiler can be used with version 3.09, can
>it?

According the customer support people at CCS,  yes it can.

Regards

Werner
--
Werner Terreblanche   Tel +27 21 7102251   Fax +27 21 721278
wterrebspamspam_OUTplessey.co.za (work) OR @spam@wernerKILLspamspamaztec.co.za  (home)

More... (looser matching)
- Last day of these posts
- In 1996 , 1997 only
- Today
- New search...