Searching \ for '[SX] 50 MHz resonator usage vs 20 MHz resonator us' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/timers.htm?key=sx
Search entire site for: '50 MHz resonator usage vs 20 MHz resonator us'.

Exact match. Not showing close matches.
PICList Thread
'[SX] 50 MHz resonator usage vs 20 MHz resonator us'
2008\07\16@042848 by tdg8934n/a

flavicon
face
In SX Microcontrollers, SX/B Compiler and SX-Key Tool, tdg8934 wrote:

I have been working on an LED Display project with another forum member that's looking very good so far but not ready for release to the completed projects forum yet. It uses many 74HC595s to shift data in across 64 columns and uses 74HC138s for the 32 rows. Everything works fine using 1 LED Display board and a 20 MHz resonator. However, the boards allow them to be daisy chained together (e.g. Signals are passed through with IN and OUT connectors) and when I do this I see the correct display data (modified program for more data to be pushed out) on both LED Display boards but it flickers. This makes sense because it has 2 times as much data to push through. So when I change the FREQ line to 50_000_000 and use a 50 MHz resonator, it works but then blanks both displays out at random times (seconds to less than a minute or so). If I hit the SX52 protoboard reset button (it also works on an SX28 but havent tested it for 50 MHz yet), then the display comes back on but then goes off again almost randomly.

Is there anything I can do to make it more stable at higher frequencies like 50 MHz?

---------- End of Message ----------

You can view the post on-line at:
http://forums.parallax.com/forums/default.aspx?f=7&p=1&m=279636
Need assistance? Send an email to the Forum Administrator at forumadmin@parallax.com
The Parallax Forums are powered by dotNetBB Forums, copyright 2002-2008 (http://www.dotNetBB.com)

2008\07\16@051703 by beann/a

flavicon
face
In SX Microcontrollers, SX/B Compiler and SX-Key Tool, bean wrote:

What OSC setting are you using ? Try changing it. OSCHS1 or OSCHS2 are most common for 50MHz.
Do you have a resistor between the OSC1 and OSC2 pins ? You might need one for 50MHz (470K maybe).

Bean.

---------- End of Message ----------

You can view the post on-line at:
http://forums.parallax.com/forums/default.aspx?f=7&p=1&m=279636#m279643
Need assistance? Send an email to the Forum Administrator at forumadmin@parallax.com
The Parallax Forums are powered by dotNetBB Forums, copyright 2002-2008 (http://www.dotNetBB.com)

2008\07\16@060134 by tdg8934n/a

flavicon
face
In SX Microcontrollers, SX/B Compiler and SX-Key Tool, tdg8934 wrote:

DEVICE sx52, oschs3, TURBO, STACKX, OPTIONX
FREQ  50_000_000
Is what I have been using. This is also the same when using FREQ 20_000_000 and a 20 MHz resonator.

I will try the other (2) OSCH1 and 2 settings and if that doesn't work - try the 470K resistor method. What does the resistor do as I don't remember doing anything like this before. It might be a little hard to do on a protoboard too.

Thanks again!

---------- End of Message ----------

You can view the post on-line at:
http://forums.parallax.com/forums/default.aspx?f=7&p=1&m=279636#m279648
Need assistance? Send an email to the Forum Administrator at forumadmin@parallax.com
The Parallax Forums are powered by dotNetBB Forums, copyright 2002-2008 (http://www.dotNetBB.com)

2008\07\16@061826 by beann/a

flavicon
face
In SX Microcontrollers, SX/B Compiler and SX-Key Tool, bean wrote:

Probably OSCHS2 will work. OSCHS3 is probably over driving it.

Bean.

---------- End of Message ----------

You can view the post on-line at:
http://forums.parallax.com/forums/default.aspx?f=7&p=1&m=279636#m279651
Need assistance? Send an email to the Forum Administrator at forumadmin@parallax.com
The Parallax Forums are powered by dotNetBB Forums, copyright 2002-2008 (http://www.dotNetBB.com)

2008\07\16@062111 by tdg8934n/a
flavicon
face
In SX Microcontrollers, SX/B Compiler and SX-Key Tool, tdg8934 wrote:

I also have a Parallax metal can oscillator (never been used) for 75 MHz that maybe needed for 3 daisy chained boards - But for now, I will stick with 2 boards and a 50 MHz resonator trying out OSCH2 tonight.

Thanks again!

---------- End of Message ----------

You can view the post on-line at:
http://forums.parallax.com/forums/default.aspx?f=7&p=1&m=279636#m279652
Need assistance? Send an email to the Forum Administrator at forumadmin@parallax.com
The Parallax Forums are powered by dotNetBB Forums, copyright 2002-2008 (http://www.dotNetBB.com)

2008\07\16@141543 by tdg8934n/a

flavicon
face
In SX Microcontrollers, SX/B Compiler and SX-Key Tool, tdg8934 wrote:

I have tested the code with OSCHS3 and it blanked out the display in a couple of minutes.

I then tested the code with OSCHS2 and it has been running great for an hour so this looks like the trick here!

Thanks!

---------- End of Message ----------

You can view the post on-line at:
http://forums.parallax.com/forums/default.aspx?f=7&p=1&m=279636#m279734
Need assistance? Send an email to the Forum Administrator at forumadmin@parallax.com
The Parallax Forums are powered by dotNetBB Forums, copyright 2002-2008 (http://www.dotNetBB.com)

More... (looser matching)
- Last day of these posts
- In 2008 , 2009 only
- Today
- New search...