Searching \ for ' Please help : Problems with ICD- Hardwar' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/microchip/devprogs.htm?key=icd
Search entire site for: 'Please help : Problems with ICD- Hardwar'.

No exact or substring matches. trying for part
PICList Thread
'[PICLIST] Please help : Problems with ICD- Hardwar'
2001\01\17@133546 by David Gomez Otero

flavicon
face
Hi,

does anybody know what is the configuration that MPLAB-ICD needs in the Serial port for connecting to the ICD Debugger.

I have built it and it seems to work  (the led flashes showing that there's no connection)  but the MPLAB doesn't see the Hard.

I use the following config :

19200bps,
data bits = 8
parity = none
stop  = 1 bit
flux control :   hardware

and I have disabled the FIFO buffer

I think that is all Microchip says but it doen't connect.
does anybody know what can happen ?
thanks
david

--
http://www.piclist.com hint: PICList Posts must start with ONE topic:
[PIC]:,[SX]:,[AVR]: ->uP ONLY! [EE]:,[OT]: ->Other [BUY]:,[AD]: ->Ads


2001\01\17@133947 by Duane Brantley

flavicon
face
I run mine off Comm1 at 9600, 8, N, 1 and no flow control.   Works for me...

-----Original Message-----
From: David Gomez Otero [spam_OUTdavid.gomezTakeThisOuTspamUPCNET.ES]
Sent: Wednesday, January 17, 2001 12:37 PM
To: .....PICLISTKILLspamspam@spam@MITVMA.MIT.EDU
Subject: Please help : Problems with ICD- Hardware


Hi,

does anybody know what is the configuration that MPLAB-ICD needs in the
Serial port for connecting to the ICD Debugger.

I have built it and it seems to work  (the led flashes showing that there's
no connection)  but
the MPLAB doesn't see the Hard.

I use the following config :

19200bps,
data bits = 8
parity = none
stop  = 1 bit
flux control :   hardware

and I have disabled the FIFO buffer

I think that is all Microchip says but it doen't connect.

does anybody know what can happen ?

thanks
david


--
http://www.piclist.com hint: PICList Posts must start with ONE topic:
[PIC]:,[SX]:,[AVR]: ->uP ONLY! [EE]:,[OT]: ->Other [BUY]:,[AD]: ->Ads

--
http://www.piclist.com hint: PICList Posts must start with ONE topic:
[PIC]:,[SX]:,[AVR]: ->uP ONLY! [EE]:,[OT]: ->Other [BUY]:,[AD]: ->Ads


2001\01\17@140436 by David Gomez Otero

flavicon
face
but, in the MPLAB ICD window you can only choose between 19600 bps and
57600bps ???

by the way,  have you built your own ICD ???

----- Original Message -----
From: Duane Brantley <Duane.BrantleyspamKILLspamGENBAND.COM>
To: <.....PICLISTKILLspamspam.....MITVMA.MIT.EDU>
Sent: Wednesday, January 17, 2001 7:39 PM
Subject: Re: Please help : Problems with ICD- Hardware


> I run mine off Comm1 at 9600, 8, N, 1 and no flow control.   Works for
me...
>
> {Original Message removed}

2001\01\18@073738 by o-8859-1?Q?K=FCbek_Tony?=

flavicon
face
I don't think it's the actual speed that's the culprit here.
How did you build it ?
I xerox'ed :) mine from the protoboard accompanying the icd.
( almost anyway ) I added an socket for oscillator and max203E
but that is ofcource flavor dependant.
Anyway here is my connections:

Mod. conn       PIC
--------        --------
1               RB3
2               RB6
3               RB7
4               Vss  ( GND ), Diode to pin 5 in modular connector
5               Vdd     ( +V )
6               Vpp/MCLR, Pullup 47k to Vdd


I think they are ok ( could be reversed on the modular connector ).
Note the pullup on MCLR !! ( this could ofcource be placed on the target
)

/Tony







Tony Kübek, Flintab AB            
²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²
E-mail: EraseMEtony.kubekspam_OUTspamTakeThisOuTflintab.com
²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²²

--
http://www.piclist.com hint: The list server can filter out subtopics
(like ads or off topics) for you. See http://www.piclist.com/#topics


2001\01\18@175030 by David Gomez Otero

flavicon
face
I have copied the exact schematic from microchip.

david

----- Original Message -----
From: K|bek Tony <tony.kubekspamspam_OUTFLINTAB.COM>
To: <@spam@PICLISTKILLspamspamMITVMA.MIT.EDU>
Sent: Thursday, January 18, 2001 10:07 AM
Subject: Re: Please help : Problems with ICD- Hardware


I don't think it's the actual speed that's the culprit here.
How did you build it ?
I xerox'ed :) mine from the protoboard accompanying the icd.
( almost anyway ) I added an socket for oscillator and max203E
but that is ofcource flavor dependant.
Anyway here is my connections:

Mod. conn       PIC
--------        --------
1               RB3
2               RB6
3               RB7
4               Vss  ( GND ), Diode to pin 5 in modular connector
5               Vdd     ( +V )
6               Vpp/MCLR, Pullup 47k to Vdd


I think they are ok ( could be reversed on the modular connector ).
Note the pullup on MCLR !! ( this could ofcource be placed on the target
)

/Tony







Tony K|bek, Flintab AB
222222222222222222222222222222222222222222222222222222222222
E-mail: KILLspamtony.kubekKILLspamspamflintab.com
222222222222222222222222222222222222222222222222222222222222

--
http://www.piclist.com hint: The list server can filter out subtopics
(like ads or off topics) for you. See http://www.piclist.com/#topics

--
http://www.piclist.com hint: The list server can filter out subtopics
(like ads or off topics) for you. See http://www.piclist.com/#topics


2001\01\18@175239 by briang

flavicon
face
In-Reply-To: <029501c080b8$5623d2e0$2486a6d4@spock>

In-Reply-To: <029501c080b8$5623d2e0$2486a6d4@spock>

David Gomez Otero <RemoveMEdavid.gomezTakeThisOuTspamUPCNET.ES> wrote:

> but, in the MPLAB ICD window you can only choose between 19600 bps and
> 57600bps ???

The ICD should work at either 19200 or 57600.
It adjusts automatically.

Brian Gregory.
spamBeGonebriangspamBeGonespamcix.compulink.co.uk

--
http://www.piclist.com hint: The list server can filter out subtopics
(like ads or off topics) for you. See http://www.piclist.com/#topics


More... (looser matching)
- Last day of these posts
- In 2001 , 2002 only
- Today
- New search...