Searching \ for ' [PIC] UART problem solved (sort of)' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/microchip/devices.htm?key=pic
Search entire site for: 'UART problem solved (sort of)'.

No exact or substring matches. trying for part
PICList Thread
'[PICLIST] [PIC] UART problem solved (sort of)'
2000\09\08@033101 by Damien Kee

flavicon
picon face
I have it partially solved.

Alexandre has said that the internal pull-ups are activated only when
writing to the whole port, and not when manipulating individual
bits.  From the documentation though, I can't seem to find any control
bits for pull-up resistors for PORTC.

So what i've done is initially written to the whole port, 0xFF.  Luckily
I'm not using PORTC for anything else and seems to have fixed the
problem.....  for now.

Thanks to everyone for your help.

cheers
damo


Damien Kee
3rd Year Electrical Engineering
University of Queensland
spam_OUTs369472TakeThisOuTspamstudent.uq.edu.au

--
http://www.piclist.com hint: To leave the PICList
.....piclist-unsubscribe-requestKILLspamspam@spam@mitvma.mit.edu>

2000\09\08@033724 by Michael Rigby-Jones

flavicon
face
I'm sure there was some discussion on this a while back on the list as to
whether the TRIS registers needed to be set or not in order to be able to
use the USART.  Opinion was divided!  Normaly peripherals will overide the
TRIS and data latch settings, but the USART does seem to be a little fussy.
A definative answer would be nice.

Mike

> {Original Message removed}

2000\09\08@063305 by Chunhee Song

flavicon
face

--
http://www.piclist.com hint: To leave the PICList
piclist-unsubscribe-requestspamKILLspammitvma.mit.edu>

More... (looser matching)
- Last day of these posts
- In 2000 , 2001 only
- Today
- New search...