Searching \ for ' (not) talking to 24LC32' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/index.htm?key=
Search entire site for: 'talking to 24LC32'.

No exact or substring matches. trying for part
PICList Thread
'[PICLIST] PIC: (not) talking to 24LC32'
2000\10\06@090812 by John Walshe

flavicon
face
Hi Folks,
   I don't often post but this one has me beaten. I'm simply connecting a
24LC32 to a 17C44 RB2(SDA) and RB3(SCL). I have a pullup resistor on SDA and
my waveforms appear to be correct. However I'm not having success.

Does anyone out there have any C code (preferably Hitech) which could help
me out of this bind.

The problem that I see is that I appear to have no response from the
24LC32 - not even an ack to the command byte.
I put a stop before the start just in case it might be in an unknown state
beforehand - but no joy.

Any advice welcome.

Thanks in advance
John Walshe

PS yes it has power and no it is not dead (I've already replaced it once !)

***************************************************************
spam_OUTJohn.WalsheTakeThisOuTspaminpactmicro.com

INPACT MICROELECTRONICS (Irl) Ltd
WWW.INPACTMICRO.COM
***************************************************************

--
http://www.piclist.com hint: The PICList is archived three different
ways.  See http://www.piclist.com/#archives for details.


'[PICLIST] (not) talking to 24LC32'
2000\10\06@094204 by Michael Rigby-Jones

flavicon
face
Are you sure you are addressing the device correctly?   Check the state of
the address pins on the eeprom and ensure this ties with the slave address
you are actually sending.

Mike

> {Original Message removed}

More... (looser matching)
- Last day of these posts
- In 2000 , 2001 only
- Today
- New search...