Searching \ for '[PIC]MPLAB install problem' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/microchip/languages.htm?key=mplab
Search entire site for: 'MPLAB install problem'.

Exact match. Not showing close matches.
PICList Thread
'[PIC]MPLAB install problem'
2007\07\26@031152 by Roy

flavicon
face
I just down loaded MPLAB version 7.60a and when I installed it onto my
windows 2000 system had the following error messages right at the end of the
install process.

Can anyone help with this or do you have a Microcip address I can report
these errors to?


RegisterServer failed in SRCVW.DLL Return=0x80070005. GetLastError = 0x0).

Error 1904.Module C:\Program Files\Microchip IDE\Core\Editor\MPUScrcvw4.dll
failed to register. HRESULT - 2147220473. Contact your support personal.

_______________________________________

Roy Hopkins             ZL2RJH
Tauranga
New Zealand
_______________________________________


2007\07\26@062227 by Jan-Erik Soderholm

face picon face
A related question.
I have currently 7.60 (so it says anyway).
What does the "a" in 7.60a add to that ?
I've tried to find a specific 7.60a-readme, but
could not.

Jan-Erik.

Roy wrote:
{Quote hidden}

2007\07\26@063510 by Roy

flavicon
face
I do not know what the "a" is but have reverted to MPLAB 7.10 (just happened
to have kept a copy of this version) which installed ok.

Only need the basic system to program one chip for a friend's project :-)

_______________________________________

Roy Hopkins             ZL2RJH
Tauranga
New Zealand
_______________________________________


> {Original Message removed}

2007\07\26@065955 by Nicola Perotto

picon face
The last release is 7.61 a
I noted that the "a" release is (for Microchip) a fast correction to a
big bug... or anything similar ;-(
So if there is a "a" and a non "a" maybe it's better to get the "a" !


Roy wrote:
{Quote hidden}

>> {Original Message removed}

2007\07\26@073907 by Jan-Erik Soderholm

face picon face
Nicola Perotto wrote:
> The last release is 7.61 a

An "interim" release, that I've always read as "beta" and
not to be used if you don't actualy *need* the changes. I never
uses the interim releases anyway. Is that a missinterpretation
of "intrim" ?

Jan-Erik.

2007\07\26@075803 by Nicola Perotto

picon face
Once, 3 or 4 years ago,  them said that every month there will be a new
release of MPLAB with small changes (Interim release) and every three
month a major release.
This is because there are often new pics, not only bug fixes!
So I never interpreted Interim as Beta.
But i dont install every version, of course, before I read the readme...
The thing I'm sure is that about "a" version: the non "a" has some big
problem.
   Nic


Jan-Erik Soderholm wrote:
{Quote hidden}

2007\07\26@081432 by Jan-Erik Soderholm

face picon face
OK, seems logical. Now, a final question... :-)
You are running 7.60*a*, right ?
Does it say "a" in the "Help -> About" box in MPLAB ?

Jan-Erik.

Nicola Perotto wrote:
{Quote hidden}

2007\07\26@083224 by Nicola Perotto

picon face
I'm running the 7.61 a but in the about it says only 7.60.00 :-(


Jan-Erik Soderholm wrote:
{Quote hidden}

2007\07\26@084630 by Nicola Perotto

picon face
Sorry... a typo

MPLAB           7.61.00.00    Certified


Nicola Perotto wrote:
{Quote hidden}

2007\07\26@084941 by Jan-Erik Soderholm

face picon face
OK.
It can't be that much work to keep the aboutbox
up-to-date, can it ? :-)

Thanks anyway !

Jan-Erik.

Nicola Perotto wrote:
{Quote hidden}

2007\07\27@013822 by Chetan Bhargava

picon face
Try to install all the windows updates and try installing MPLAB again.
In the release note it says it is supported on Windows(r) 2000 SP4.

I have seen some software fail to work if all the updates are not applied.


On 7/26/07, Roy <spam_OUTroy.hTakeThisOuTspamihug.co.nz> wrote:
> Error 1904.Module C:\Program Files\Microchip IDE\Core\Editor\MPUScrcvw4.dll
> failed to register. HRESULT - 2147220473. Contact your support personal.


--
Chetan Bhargava
Web: http://www.bhargavaz.net
Blog: http://microz.blogspot.com

2007\07\27@023328 by Roy

flavicon
face
Thanks for the reply,

I had service pack 4 installed when I received the errors :-(

This thread can be dropped now as I have reverted to an earlier version of
MPLAB 7.1 for now, I only needed it installed for a one of PIC programming
exercise for a friend.

_______________________________________

Roy Hopkins             ZL2RJH
Tauranga
New Zealand
_______________________________________

> {Original Message removed}

2007\07\27@083930 by Xiaofan Chen

face picon face
On 7/26/07, Jan-Erik Soderholm <.....jan-erik.soderholmKILLspamspam@spam@telia.com> wrote:
> A related question.
> I have currently 7.60 (so it says anyway).
> What does the "a" in 7.60a add to that ?
> I've tried to find a specific 7.60a-readme, but
> could not.

I happened to receive an email from Microchip which explained the
reason.

"To A or Not To A
Joe Drzewiecki

OK, there has been a little double clutching in v7.60 and v7.61, namely
quickly released A versions released soon after the originals. Mea culpa!

Let me explain. In version 7.60 a detrimental build flag got mysteriously set in
the MPLAB IDE base component and it wouldn't let any unsigned (not MCHP)
plug-ins load. That was bad. For instance, the LabCenter Proteus plug-in got
ignored. 7.60a fixed that bug. With reference to 7.61, it was sound as a dollar
from an execution standpoint. Unfortunately, one of the support files had
references to a certain unreleased device family. Oops! 7.61a fixed that."

Hope this claries things.

Xiaofan

2007\07\27@120339 by Jan-Erik Soderholm

face picon face
OK, thanks.
It's still a bit unprofessional *not* to have a readme
for the "a" version, even if it's only a few lines...

And finaly, he didn't say what that "certain unreleased
device family" is ? Something interesting ? Could someone
run a "diff" on the "non-a" vs. "a" support files ? :-):-)

An unreleased device *family* seems as a major new release,
doesn't it ?

Jan-Erik.



Xiaofan Chen wrote:
{Quote hidden}

2007\07\27@124754 by Xiaofan Chen

face picon face
On 7/27/07, Jan-Erik Soderholm <.....jan-erik.soderholmKILLspamspam.....telia.com> wrote:
>
> An unreleased device *family* seems as a major new release,
> doesn't it ?
>

I did not copy all the words. He did say that
"It's a varied lot and quite a load for a DOT release."

There are some other words which I do not want to include since it
is a bit contraditing to what I read from the forum.

Xiaofan

2007\07\28@101742 by Howard Winter

face
flavicon
picon face
Jan-Erik,

On Thu, 26 Jul 2007 13:39:05 +0200, Jan-Erik Soderholm wrote:

> Nicola Perotto wrote:
> > The last release is 7.61 a
>
> An "interim" release, that I've always read as "beta" and
> not to be used if you don't actualy *need* the changes. I never
> uses the interim releases anyway. Is that a missinterpretation
> of "intrim" ?

If I understand their thinking correctly, the .01 part is what makes it "interim" - the "a" part is what makes it a quick "oops!" correction.

So if I'm right the next "full" release will be 7.70 or 8.00, but there may be more interims called 7.62, etc.

Cheers,


Howard Winter
St.Albans, England


2007\07\30@080313 by Alan B. Pearce

face picon face
>With reference to 7.61, it was sound as a dollar from an
>execution standpoint. Unfortunately, one of the support
>files had references to a certain unreleased device family.
>Oops! 7.61a fixed that."

Hmm, rapid scramble to find the 'unreleased device family' in archive copies
...

I wonder what is coming up RSN (tm) ...

More... (looser matching)
- Last day of these posts
- In 2007 , 2008 only
- Today
- New search...