Searching \ for '[PIC] Problem with the new MPLAB v8.80' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/microchip/languages.htm?key=mplab
Search entire site for: 'Problem with the new MPLAB v8.80'.

Exact match. Not showing close matches.
PICList Thread
'[PIC] Problem with the new MPLAB v8.80'
2011\11\06@073408 by Electron

flavicon
face

Hello,
I've just installed the new MPLAB v8.80, coming from v8.76.

---

I now get a lot of errors, e.g.:

In file included from c:\utility\electronics\mplab\mplab c32 suite\bin\../lib/gcc/pic32mx/4.5.1/../../../../pic32mx/include/peripheral/dma.h:40:0,
                from c:\utility\electronics\mplab\mplab c32 suite\bin\../lib/gcc/pic32mx/4.5.1/../../../../pic32mx/include/plib.h:45,
                from v001_C.C:22:
c:\utility\electronics\mplab\mplab c32 suite\bin\../lib/gcc/pic32mx/4.5.1/.../../../../pic32mx/include/peripheral/dma_3xx_4xx.h:827:19: error: '_DMACON_FRZ_MASK' undeclared here (not in a function)
In file included from c:\utility\electronics\mplab\mplab c32 suite\bin\../lib/gcc/pic32mx/4.5.1/../../../../pic32mx/include/plib.h:56:0,
                from v001_C.C:22:
c:\utility\electronics\mplab\mplab c32 suite\bin\../lib/gcc/pic32mx/4.5.1/.../../../../pic32mx/include/peripheral/rtcc.h: In function 'RtccFreezeEnable':
c:\utility\electronics\mplab\mplab c32 suite\bin\../lib/gcc/pic32mx/4.5.1/.../../../../pic32mx/include/peripheral/rtcc.h:1323:13: error: '_RTCCON_FRZ_MASK' undeclared (first use in this function)
c:\utility\electronics\mplab\mplab c32 suite\bin\../lib/gcc/pic32mx/4.5.1/.../../../../pic32mx/include/peripheral/rtcc.h:1323:13: note: each undeclared identifier is reported only once for each function it appears in
c:\utility\electronics\mplab\mplab c32 suite\bin\../lib/gcc/pic32mx/4.5.1/.../../../../pic32mx/include/peripheral/rtcc.h: In function 'RtccGetFreeze':
c:\utility\electronics\mplab\mplab c32 suite\bin\../lib/gcc/pic32mx/4.5.1/.../../../../pic32mx/include/peripheral/rtcc.h:1351:19: error: '__RTCCONbits_t' has no member named 'FRZ'
In file included from c:\utility\electronics\mplab\mplab c32 suite\bin\../lib/gcc/pic32mx/4.5.1/../../../../pic32mx/include/peripheral/spi.h:44:0,
                from c:\utility\electronics\mplab\mplab c32 suite\bin\../lib/gcc/pic32mx/4.5.1/../../../../pic32mx/include/plib.h:57,
                from v001_C.C:22:
c:\utility\electronics\mplab\mplab c32 suite\bin\../lib/gcc/pic32mx/4.5.1/.../../../../pic32mx/include/peripheral/spi_3xx_4xx.h: At top level:
c:\utility\electronics\mplab\mplab c32 suite\bin\../lib/gcc/pic32mx/4.5.1/.../../../../pic32mx/include/peripheral/spi_3xx_4xx.h:139:1: error: '_SPI1CON_FRZ_MASK' undeclared here (not in a function)
Halting build on first failure as requested.

---

Any clue? Past MPLAB updates, loading the same Workbench, didn't result in any problems.

Cheers,
Mario

2011\11\06@093128 by Electron

flavicon
face
{Quote hidden}

PS: I loaded my dsPIC Workspace and it worked like charme.

The problem is only with my current PIC32 project's Workspace.. does
anybody have a clue why it's happening?

2011\11\06@095953 by Isaac Marino Bavaresco

flavicon
face
Em 6/11/2011 12:31, Electron escreveu:
{Quote hidden}

Perhaps the new installation also installed the MPLAB C32 again? The new
version may have some incompatibility or it is a limited demo version.


Isaac

2011\11\06@102234 by Electron

flavicon
face
At 15.51 2011.11.06, you wrote:
{Quote hidden}

Yes, I have chosen it (as it is a newer version). Should I have uninstalled
the previous v8.76 MPLAB before installing the new v8.80?


>The new version may have some incompatibility or it is a limited demo version.

I already spotted differences, e.g. using $ before register name in asm.

But the above errors seem different, like if it can't find include files.

I'll try to include them manually to see what happens (mushroom cloud incoming).



>
>
>Isaac
>
>

2011\11\06@104258 by Chris Roper

picon face
I for one would be interested in your results.

I was about to do the upgrade myself, but as all my important code is
in C32 and a deadline fast  approaching, I had better hold off
upgrading till the pressure is off

2011\11\06@110234 by Electron

flavicon
face
At 16.42 2011.11.06, you wrote:
>I for one would be interested in your results.
>
>I was about to do the upgrade myself, but as all my important code is
>in C32 and a deadline fast  approaching, I had better hold off
>upgrading till the pressure is off.

>From my experience I'd suggest not to upgrade until you can revert
easily without putting yourself in trouble. In the past I always made
backups before upgrading MPLAB, and no problem ever arised. This time
I didn't.

It's the definitive proof, if needed, that the Murphy's Law is true. ;)

And here I am stuck with the PIC32 project (but the dsPIC one keeps on
working, so MPLAB is half nasty and half nice, depends on your # of bits).

Anyhow, I can always uninstall it and reinstal v8.76 in case trying to
fix it gets boring, but the new v8.80 has support for some new chips
which I'm very interested into simulating, although they are not yet
available (the new 1x PIC32's).

Cheers,
MarI/O

2011\11\06@130607 by Harold Hallikainen

face
flavicon
face

>> The problem is only with my current PIC32 project's Workspace.. does
>> anybody have a clue why it's happening?
>>
>
>
> Perhaps the new installation also installed the MPLAB C32 again? The new
> version may have some incompatibility or it is a limited demo version.
>
>
> Isaac

I did an update of C32 last week without an update to MPLAB. I got the
same sort of issues (mostly complaining about dma.h). I ended up restoring
to a disk image from the previous day. Mirochip Forums on PI32 indicates
that there's also an issue with printf in the new version of C32.

Harold



-- FCC Rules Updated Daily at http://www.hallikainen.com - Advertising
opportunities available

2011\11\07@004811 by Oli Glaser

flavicon
face
On 06/11/2011 18:05, Harold Hallikainen wrote:
>>> The problem is only with my current PIC32 project's Workspace.. does
>>> anybody have a clue why it's happening?
>>>
>>
>> Perhaps the new installation also installed the MPLAB C32 again? The new
>> version may have some incompatibility or it is a limited demo version.
>>
>>
>> Isaac
> I did an update of C32 last week without an update to MPLAB. I got the
> same sort of issues (mostly complaining about dma.h). I ended up restoring
> to a disk image from the previous day. Mirochip Forums on PI32 indicates
> that there's also an issue with printf in the new version of C32.
>
> Harold
>
>
>

I have had some real issues with updating MPLAB. I ended up with an old version in my control panel->programs/features that wouldn't go away (i.e. I pressed uninstall and nothing happened)
Nothing /particularly/ bad was happening, but the update always found the old version, amongst some other little oddities like different version of compilers getting mixed up.
In the end I reinstalled the old version (the one that refused to budge when asked politely) again, then uninstalled everything I could, then cleaned the registry (with a utility and manually) and reinstalled the latest version of everything, rebooted, waved dead fish three times over laptop whilst standing on one leg, etc.
Anyway, it's been working very nicely since then (the dead fish technique is very effective), and all code written on previous versions compiles okay (including PIC32 stuff)
There are a few threads on MCHP forums about MPLAB installation issues, plus a page of advice somewhere about what you should do if your installation goes wonky.

More... (looser matching)
- Last day of these posts
- In 2011 , 2012 only
- Today
- New search...