Searching \ for '[PIC] 18F4550 USB problem' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/microchip/devices.htm?key=18F
Search entire site for: '18F4550 USB problem'.

Exact match. Not showing close matches.
PICList Thread
'[PIC] 18F4550 USB problem'
2007\10\15@183331 by Andre Abelian

flavicon
face

Hi to all,

I have C code modified from CCS example code when I program
their demo board it works fine but when I try my board I made
the only different is I use external oscillator it doesn't work.
My question is does external oscillator requires change other then
HSPLL to ECPLL. I even replaced the pic still it doesn't work.
Any idea?

thanks

Andre

2007\10\15@185049 by peter green

flavicon
face
Andre Abelian wrote:
> Hi to all,
>
> I have C code modified from CCS example code when I program
> their demo board it works fine but when I try my board I made
> the only different is I use external oscillator it doesn't work.
> My question is does external oscillator requires change other then
> HSPLL to ECPLL.
Is your oscilator the same speed as thiers and if not did you remember
to change the pll divider to match?

have you actually changed the setting? remember every time you compile
changes made in the mplab IDE are overwritten by any changes made in the
code.

is your oscilator actually the frequency you think it is? (I remember
having a load of problems when a supplier sent 4.433mhz crystals rather
than 4mhz crystals)

is your oscilator of appropriately tight tollerance (iirc it has to be
within something like 100ppm)

2007\10\15@233616 by Andre

flavicon
face
I use 20 Mhz osc and I changed it to ECPLL. I tested 2 different demo boards
that both of them use 20 Mhz crystal they work fine. I am not sure if there
is any
different if OSC is used?

thanks

Andre


{Original Message removed}

2007\10\16@181706 by alan smith

picon face
well...coulld always go back to the simple example of flashing an LED on your target board, make sure the PIC is actually cycling code on it.

spam_OUTandreTakeThisOuTspamditechnology.com wrote:  I use 20 Mhz osc and I changed it to ECPLL. I tested 2 different demo boards
that both of them use 20 Mhz crystal they work fine. I am not sure if there
is any
different if OSC is used?

thanks

Andre


{Original Message removed}

More... (looser matching)
- Last day of these posts
- In 2007 , 2008 only
- Today
- New search...