Searching \ for '[PIC] 16F505 - wont enter debug' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/microchip/devices.htm?key=16F
Search entire site for: '16F505 - wont enter debug'.

Exact match. Not showing close matches.
PICList Thread
'[PIC] 16F505 - wont enter debug'
2008\07\23@175623 by alan smith

picon face
last time I had an issue, it was a LVP or such configuration bit.  The '505 is so bare bones...internal osc, mclr, wdt....nothing I can see that would prevent it from going into debug.  Anyone have a suggestion?  I'm traveling this week, so hopefully might see an answer today before I hit the road.

It does connect, says it programs, just wont enter the debug mode


     

2008\07\23@182137 by Funny NYPD

picon face
Some of those chips need a special made header for in circuit debugging, do you have one?

Funny N.
Au Group Electronics, New Bedford, MA, http://www.AuElectronics.com



{Original Message removed}

2008\07\23@185019 by Harold Hallikainen

face
flavicon
face
I just brought this chip up on MPLAB. It has a green dot (debugging
supported) for the simulator and ICE2000. It appears no other debugging is
supported.

Harold


> Some of those chips need a special made header for in circuit debugging,
> do you have one?
>
>  Funny N.
> Au Group Electronics, New Bedford, MA, http://www.AuElectronics.com
>
>
>
> {Original Message removed}

2008\07\23@185639 by Xiaofan Chen

face picon face
On Thu, Jul 24, 2008 at 6:21 AM, Funny NYPD <spam_OUTfunnynypdTakeThisOuTspamyahoo.com> wrote:
> Some of those chips need a special made header for in
> circuit debugging, do you have one?
>

All the base line PICs and some mid-range PICs needs ICD header
since they do not have the debug silicon built-in.
16F505 is a base line PIC.

The following URL has the list. It is written for PICkit 2 but applies the
same to MPLAB ICD2.
http://www.microchip.com/stellent/idcplg?IdcService=SS_GET_PAGE&nodeId=1406&dDocName=en027813

Xiaofan

2008\07\23@190018 by David Meiklejohn

face
flavicon
face
alan smith wrote:
>
> last time I had an issue, it was a LVP or such configuration bit.  The
> '505 is so bare bones...internal osc, mclr, wdt....nothing I can see that
> would prevent it from going into debug.  Anyone have a suggestion?  I'm
> traveling this week, so hopefully might see an answer today before I hit
> the road.
>
> It does connect, says it programs, just wont enter the debug mode

Are you using a debug header?  (16F505-ICD).  You can use an ICSP
programmer (e.g. PICkit 2, ICD2) to program the bare 16F505, but it has no
debug support on chip and so needs the -ICD header.


David Meiklejohn
http://www.gooligum.com.au

2008\07\23@191849 by Richard Seriani, Sr.

picon face

----- Original Message -----
From: "Harold Hallikainen" <.....haroldKILLspamspam@spam@hallikainen.org>
To: "Microcontroller discussion list - Public." <piclistspamKILLspammit.edu>
Cc: "Microcontroller discussion list - Public." <.....piclistKILLspamspam.....mit.edu>
Sent: Wednesday, July 23, 2008 6:49 PM
Subject: Re: [PIC] 16F505 - wont enter debug


>I just brought this chip up on MPLAB. It has a green dot (debugging
> supported) for the simulator and ICE2000. It appears no other debugging is
> supported.
>
> Harold
>

It looks like there is also beta support for PICkit2 debugging (yellow dot).
PICkit2 documentation also indicates debug support.

Which hardware are you using?

Richard


{Quote hidden}

More... (looser matching)
- Last day of these posts
- In 2008 , 2009 only
- Today
- New search...