Searching \ for '[PIC]:PICStart+ and 18F452' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/microchip/devices.htm?key=18F
Search entire site for: 'PICStart+ and 18F452'.

Exact match. Not showing close matches.
PICList Thread
'[PIC]:PICStart+ and 18F452'
2002\08\21@005537 by Scott Dattalo

face
flavicon
face
Has anybody got this combination to work?

I've tried MPLAB 5.70.00. I upgraded my PICStart+ firmware to the latest
version (3.0.00) and tried to read the contents of an 18f452. It hangs at
address 0x7FE2 and puts up a dialog box:

  Communication error
     Cannot Receive.....

      [0000,00,00,54]

I've also occasionally see the error:

 Connect
   Unsupported programmer detected, 28

(I assume they're referring to the PICStart+ and not me.)

I figured my 4 year old PICStart+ was now too old. So I bought a new one
and $200 bucks later see the same damn error.

Do I have a couple of boat anchors now or does anyone know what may be
happening?

Scott

--
http://www.piclist.com hint: The list server can filter out subtopics
(like ads or off topics) for you. See http://www.piclist.com/#topics


2002\08\21@043246 by Alan B. Pearce

face picon face
>   Communication error
>      Cannot Receive.....

Are you using a dual processor machine ??

Check the PICStart Plus readme on how to get around this if you are.

--
http://www.piclist.com hint: The list server can filter out subtopics
(like ads or off topics) for you. See http://www.piclist.com/#topics


2002\08\21@102023 by Dave Mumert

flavicon
face
Hi All

I get the same sort of problems since I upgraded to FW 3.0.  The PS+ works
fine with the older FW.  Since the only change to the system was going from
FW2.3 to FW3.0 I can pretty safely conclude that the problem lies with the
new FW.

I sent a message to tech support at Microchip but got back a generic answer

'Make sure you have the FIFO box not checked.  All of our suggestions for
communication problems with the PICSTART Plus programmer are contained in
the PICSTART Plus help file under Troubleshooting Common Problems. '

I thought this was a bit insulting, as I had indicated in my message that I
had tried all that already.

Let us know if you get this resolved.

Dave


{Quote hidden}

--
http://www.piclist.com hint: The list server can filter out subtopics
(like ads or off topics) for you. See http://www.piclist.com/#topics


2002\08\21@105405 by Jennifer L. Gatza

flavicon
face
I am running MPLAB 5.70 on two computers (my desktop and my notebook), and I
share one PICSTART Plus (fw v.3.0) between them.  I have no problems with
this configuration on my desktop (running W2K). The notebook, running XP,
causes the same problem you described.  I just assumed that this was one of
the compatibility issues with XP - note that it is not on the list of
supported OS's.

To get around it in the field, I learned that this is a semi-random error.
If it doesn't program correctly on the first attempt, it will by the second
or third try.  It's a little slower this way, but it's easier than changing
the OS on a notebook and finding all new proprietary drivers that work
*properly* - especially since I get paid for time with a client, and I don't
get paid for upgrading my computer.

Jen

> {Original Message removed}

2002\08\21@121431 by Mike Mansheim

flavicon
face
>  Communication error

I had communication problems with a promate that were fixed by changing
two serial port settings:
- "hardware" flow control
- in the advanced section, make sure the "Use FIFO..." box is NOT checked

--
http://www.piclist.com hint: The list server can filter out subtopics
(like ads or off topics) for you. See http://www.piclist.com/#topics


2002\08\23@011931 by Scott Dattalo

face
flavicon
face
On Tue, 20 Aug 2002, Scott Dattalo wrote:

> Has anybody got this combination to work?

I resolved the issue. I tried a different computer and it worked.

Failed on: Compaq Armada E500 Laptop

Passed on: E-machines Celeron Dinosaur

My two boat anchors are now paddles.

Scott

--
http://www.piclist.com#nomail Going offline? Don't AutoReply us!
email spam_OUTlistservTakeThisOuTspammitvma.mit.edu with SET PICList DIGEST in the body


More... (looser matching)
- Last day of these posts
- In 2002 , 2003 only
- Today
- New search...