Searching \ for '[PIC]: ICD Problem' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/microchip/devprogs.htm?key=icd
Search entire site for: 'ICD Problem'.

Exact match. Not showing close matches.
PICList Thread
'[PIC]: ICD Problem'
2002\08\27@093725 by Lennart Sundberg

picon face
I am trying to run the ICD for the first time to check out how well the ICD function. I have assembled a very simple program and downloaded it to a PIC16F877. The program lights a few LED's when I push a switch.  I can program the chip with ICD and the program works fine in stand alone mode.
 The problem is that when I select debug mode I can single step and do animate stepping only with the fastest Upload Option: Minimum (FSR, W, Status, PCLATH) (Very Fast) and with Minimum and watch windows, other upload options gives communication errors.
 And if I try to run with the ICD without any breakpoints the processor halts directly?
Also after a reset the programcounter is set to pc:0x16  shouldn't it be zero or 0x05 where my program starts?
Have I missed something or have I problem with my serial port on my computer?
Please give me a hint.
/Lennart

--
http://www.piclist.com hint: The PICList is archived three different
ways.  See http://www.piclist.com/#archives for details.


2002\08\27@094640 by Samuel BOUQUET

flavicon
face
you have to insert code which can do the debug of your code.
With CCS-C Compiler, i just have to write ICD=TRUE on the #device line.


-----Message d'origine-----
De : pic microcontroller discussion list
[spam_OUTPICLISTTakeThisOuTspamMITVMA.MIT.EDU]De la part de Lennart Sundberg
Envoyi : mardi 27 ao{t 2002 15:21
@ : .....PICLISTKILLspamspam@spam@MITVMA.MIT.EDU
Objet : [PIC]: ICD Problem


I am trying to run the ICD for the first time to check out how well the ICD
function. I have assembled a very simple program and downloaded it to a
PIC16F877. The program lights a few LED's when I push a switch.  I can
program the chip with ICD and the program works fine in stand alone mode.
 The problem is that when I select debug mode I can single step and do
animate stepping only with the fastest Upload Option: Minimum (FSR, W,
Status, PCLATH) (Very Fast) and with Minimum and watch windows, other upload
options gives communication errors.
 And if I try to run with the ICD without any breakpoints the processor
halts directly?
Also after a reset the programcounter is set to pc:0x16  shouldn't it be
zero or 0x05 where my program starts?
Have I missed something or have I problem with my serial port on my
computer?
Please give me a hint.
/Lennart

--
http://www.piclist.com hint: The PICList is archived three different
ways.  See http://www.piclist.com/#archives for details.

--
http://www.piclist.com hint: The PICList is archived three different
ways.  See http://www.piclist.com/#archives for details.


2002\08\29@145351 by Lennart Sundberg

picon face
I found that RB6 and RB7 had each a LED connected for monitoring outputs.  The load from the LED caused the ICD communication to work funny.
Now stepping and running program works fine.
Thanks /Lennart

{Original Message removed}

More... (looser matching)
- Last day of these posts
- In 2002 , 2003 only
- Today
- New search...