Searching \ for '[PIC]: Help! PIC18C452' in subject line. ()
Make payments with PayPal - it's fast, free and secure! Help us get a faster server
FAQ page: www.piclist.com/techref/microchip/devices.htm?key=pic
Search entire site for: 'Help! PIC18C452'.

Exact match. Not showing close matches.
PICList Thread
'[PIC]: Help! PIC18C452'
2000\08\16@085441 by Thomas C. Sefranek

face picon face
[Panic Mode On]

I have just started to use the MPLAB ICE 2000 system
to debug my assembly code for the 18C452.

First error:  The First line of code does NOT GOTO! the PCL just keeps
incrimenting for as many
cycles as I step it!!!  (I assumed it needed at least 2 steps to read/run the
object code.)

000000 EF0E F000      00007                 GOTO    Restart ; Go to beginning
of the MAIN program.
.
.
.
00001C                00027 Restart                         ; Initializations
                     00028         INCLUDE <CLEARMEM.inc>  ; Global RAM Memory
Initializations.
                     00001 ;************************** CLEAR_MEM.inc
*****************************
                     00002 ; This module clears all RAM in the 452 PIC.
                     00003 ;
                     00004 ; Author: Thomas C. Sefranek  8-15-2000
                     00005

;***********************************************************************
                     00006 ;
00001C 0E06           00007 Clear_Mem       MOVLW   6               ; Form the
block Count.

I notice the ASSEMBLER is NOT producing the right code for the address of
Restart!!!
000000 EF0E F000 <--- Assembler produced.
000000 EF1C F000<--- Should be this!

Second Error:  But the ICE debugger does not even goto 0000E or 0001C!
The PCL just keeps going from 00000 to 00002 to 00004 to 00006 etc.

I am using  MPLAB IDE V5.11 and I know it's been suggested that we load the
newer
version, but no one here can!  Olin (Upstairs) has tried several times on his
modem connection,
I have tried using our 10 base T connection and I have tried from home, all
downloads from
Microchip halt after about 200 K bytes.

I already have committed our entire system to this PIC and have PC boards....

I'm facing a deadline!

[Panic Mode Off]


--
 *
 |  __O    Thomas C. Sefranek  spam_OUTtcsTakeThisOuTspamcmcorp.com
 |_-\<,_   Amateur Radio Operator: WA1RHP
 (*)/ (*)  Bicycle mobile on 145.41, 448.625 MHz

ARRL Instructor, Technical Specialist, VE Contact.
hamradio.cmcorp.com/inventory/Inventory.html
http://www.harvardrepeater.org

--
http://www.piclist.com hint: The PICList is archived three different
ways.  See http://www.piclist.com/#archives for details.

2000\08\16@115442 by Andy Howard

picon face
: From: "Thomas C. Sefranek" <.....tcsKILLspamspam@spam@CMCORP.COM>
> [Panic Mode On]

>
> I am using  MPLAB IDE V5.11 and I know it's been suggested that we load
the
> newer
> version, but no one here can!  Olin (Upstairs) has tried several times on
his
> modem connection,
> I have tried using our 10 base T connection and I have tried from home,
all
> downloads from
> Microchip halt after about 200 K bytes.

I can't help with the ICE problem, but I too had trouble with the download
stalling (using the Web install option under W98 and IE5.5, dialed-in via
DUN on ISDN). I got around it by hitting Disconnect in the DUN window and
then when the installer complained, clicking the Retry button. After
reconnecting The installer scans past the files it's already installed and
resumes the download.  It took about 5 restarts to get the whole thing, but
it did work in the end.

Maybe they're just swamped with peole upgrading from the flakey 5.11.


Hope this helps.


Andy















.

--
http://www.piclist.com hint: The PICList is archived three different
ways.  See http://www.piclist.com/#archives for details.

2000\08\16@123956 by Thomas C. Sefranek

face picon face
Andy Howard wrote:

> > I am using  MPLAB IDE V5.11 and I know it's been suggested that we load
> the
> > newer
> > version, but no one here can!  Olin (Upstairs) has tried several times on
> his
> > modem connection,
> > I have tried using our 10 base T connection and I have tried from home,
> all
> > downloads from
> > Microchip halt after about 200 K bytes.
>
> I can't help with the ICE problem, but I too had trouble with the download
> stalling (using the Web install option under W98 and IE5.5, dialed-in via
> DUN on ISDN). I got around it by hitting Disconnect in the DUN window and
> then when the installer complained, clicking the Retry button. After
> reconnecting The installer scans past the files it's already installed and
> resumes the download.  It took about 5 restarts to get the whole thing, but
> it did work in the end.

We just got it by FTPing the sections as 8 disks segments.

{Quote hidden}

--
 *
 |  __O    Thomas C. Sefranek  tcsspamKILLspamcmcorp.com
 |_-\<,_   Amateur Radio Operator: WA1RHP
 (*)/ (*)  Bicycle mobile on 145.41, 448.625 MHz

ARRL Instructor, Technical Specialist, VE Contact.
hamradio.cmcorp.com/inventory/Inventory.html
http://www.harvardrepeater.org

--
http://www.piclist.com hint: The PICList is archived three different
ways.  See http://www.piclist.com/#archives for details.

More... (looser matching)
- Last day of these posts
- In 2000 , 2001 only
- Today
- New search...